re = /a.*p.*p.*h.*t.*.*c.*o.*n.*t.*s.*e.*a.*/mi
str = 'app/Http/Controllers/SearchController.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end