#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\n\r].*Divisions:?(\D3\D)?"
Local $sString = " 3, " & @CRLF & _
"SomethingThatShouldntMatch: 3, 5" & @CRLF & _
"Divisions: 1, 2, 3, 5, 13" & @CRLF & _
"Divisions: 33" & @CRLF & _
"Divisions: 3, 22" & @CRLF & _
"Divisions: 4, 55" & @CRLF & _
"Divisions: 10, 31"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")