import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\n\\r].*Divisions:?(\\D3\\D)?";
final String string = " 3, \n"
+ "SomethingThatShouldntMatch: 3, 5\n"
+ "Divisions: 1, 2, 3, 5, 13\n"
+ "Divisions: 33\n"
+ "Divisions: 3, 22\n"
+ "Divisions: 4, 55\n"
+ "Divisions: 10, 31";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}