re = /[\n\r].*Divisions:?(\D3\D)?/
str = ' 3,
SomethingThatShouldntMatch: 3, 5
Divisions: 1, 2, 3, 5, 13
Divisions: 33
Divisions: 3, 22
Divisions: 4, 55
Divisions: 10, 31'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end