using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*-?\d[\d.]*\s*\K.+";
string input = @" 13.5 0.12557 0.04243 -0.0073 0.00377
14 0.12573 0.05 -0.00697 0.00437
14.5 0.12623 0.05823 -0.00703 0.005
15 0.12853 0.0686 -0.00627 0.00493
15.5 0.1299 0.08073 -0.00533 0.0063";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}