# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*-?\d[\d.]*\s*\K.+"
test_str = (" 13.5 0.12557 0.04243 -0.0073 0.00377\n"
" 14 0.12573 0.05 -0.00697 0.00437\n"
" 14.5 0.12623 0.05823 -0.00703 0.005\n"
" 15 0.12853 0.0686 -0.00627 0.00493\n"
" 15.5 0.1299 0.08073 -0.00533 0.0063")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.