#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^C\w*(?:-\d+)?(?:-\d+)?\W*111\b"
Local $sString = "V0EQ21309-128 1 1001600535.99N0023642.63E 478409.56662024.7 107.91520748348" & @CRLF & _
"S0EQ21309-128 11 1001600532.60N0023645.31E 478450.26661919.6 0.01520748348" & @CRLF & _
"T0EQ21309-128 1 1 1001600452.10N0023713.63E 478880.66660664.0 0.01520748348" & @CRLF & _
"T0EQ21309-128 1 2 1001600452.35N0023715.00E 478901.96660671.8 0.01520748348" & @CRLF & _
"C0EQ21309-128 111 1001600532.07N0023645.24E 478449.06661903.2 0.01520748348" & @CRLF & _
"C0EQ21309-128 113 1001600532.22N0023646.01E 478461.06661907.6 0.01520748348" & @CRLF & _
"C012PA105 111 1003660607.77N0080416.09E 458009.87331794.0 365.21171920443" & @CRLF & _
"C012PA105 113 1003660607.96N0080415.12E 457997.77331800.2 365.21171920443" & @CRLF & _
"C012PA105 122 1004660607.65N0080415.58E 458003.57331790.5 365.31171920472" & @CRLF & _
"C012PA105 124 1004660607.84N0080414.62E 457991.47331796.6 365.31171920472"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")