$re = '/(^\s*)#\s(?=.*# check=nothing)(.*)$/m';
$str = 'parent:
A:
name: foo
value: x.y.z # check=something
# value: "yay" # check=nothing
B:
name: bar
value: p.q.r # check=something
# value: "yay" # check=nothing';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;