using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\/]+(?=\/$|$)";
string input = @"googleads.g.doubleclick.net/viewthroughconversion/pagead/viewthroughconversion/333/abc.beta-1234.js
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}