re = /[^\/]+(?=\/$|$)/m
str = 'googleads.g.doubleclick.net/viewthroughconversion/pagead/viewthroughconversion/333/abc.beta-1234.js
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end