$re = '/[^\/]+(?=\/$|$)/m';
$str = 'googleads.g.doubleclick.net/viewthroughconversion/pagead/viewthroughconversion/333/abc.beta-1234.js
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);