using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"server[\d]+\.akamaized\.com.*\.mpd";
string input = @"https://video.server64.akamaized.com/testdevideo/manifest.mpd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}