$re = '/server[\d]+\.akamaized\.com.*\.mpd/m';
$str = 'https://video.server64.akamaized.com/testdevideo/manifest.mpd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);