package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)server[\d]+\.akamaized\.com.*\.mpd`)
var str = `https://video.server64.akamaized.com/testdevideo/manifest.mpd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}