import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/[^\\/]+\\/).*\\1";
final String string = "/ugrad/honors/index.php/policies/sao/policies/overview/step-1-course-requirements.html\n"
+ "/ugrad/honors/index.php/overview/sao/overview/sao/policies/noodle.html";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}