import re
regex = re.compile(r"(\/[^\/]+\/).*\1", flags=re.MULTILINE)
test_str = ("/ugrad/honors/index.php/policies/sao/policies/overview/step-1-course-requirements.html\n"
"/ugrad/honors/index.php/overview/sao/overview/sao/policies/noodle.html")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")