re = /(\/[^\/]+\/).*\1/m
str = '/ugrad/honors/index.php/policies/sao/policies/overview/step-1-course-requirements.html
/ugrad/honors/index.php/overview/sao/overview/sao/policies/noodle.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end