using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*a.*href=\""(.*?)\"".*?>(.*?)<\/a>";
string substitution = @"$2 (Link->$1)";
string input = @"<a href=""http://blar.pirates.net/black/ship.html"">Go here please.</a></p><p class=""p1""><a href=""http://blar.pirates.net/black/ship.html"">http://blar.pirates.net/black/ship.html</a></p>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}