const regex = /<\s*a.*href=\"(.*?)\".*?>(.*?)<\/a>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*a.*href=\\"(.*?)\\".*?>(.*?)<\\\/a>', 'gmi')
const str = `<a href="http://blar.pirates.net/black/ship.html">Go here please.</a></p><p class="p1"><a href="http://blar.pirates.net/black/ship.html">http://blar.pirates.net/black/ship.html</a></p>`;
const subst = `$2 (Link->$1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);