// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)<\s*a.*href=\"(.*?)\".*?>(.*?)<\/a>"#).unwrap();
let string = "<a href=\"http://blar.pirates.net/black/ship.html\">Go here please.</a></p><p class=\"p1\"><a href=\"http://blar.pirates.net/black/ship.html\">http://blar.pirates.net/black/ship.html</a></p>";
let substitution = "$2 (Link->$1)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}