using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Player2\(\K\d+";
string input = @"Player1(1000m), Player2(256m), Player3(600m), Player4(600m)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}