$re = '/Player2\(\K\d+/m';
$str = 'Player1(1000m), Player2(256m), Player3(600m), Player4(600m)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);