re = /Player2\(\K\d+/m
str = 'Player1(1000m), Player2(256m), Player3(600m), Player4(600m)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end