using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[A-Z\d]|[-_.](?=[A-Z\d]))+@[-A-Z\d.]+\.[A-Z]{2,}$";
string input = @"### SHOULD WORK
rick@rick.com
rick_1@rick.com
rick.a@rick.com
rick14@ric-k14.com
rick@rick.co.gov.uk
### SHOULD NOT WORK
# UNDERSCORE IS NOT FOLLOWED BY A LETTER OR NUMBER
rick_@rick.com
# DOT IS NOT FOLLOWED BY A LETTER OR NUMBER
rick.@rick.com
# NO SPACES ALLOWED
ri ck@rick.com
# UNDERSCORE NOT ALLOWED IN DOMAIN
rick@ri_ck.com
# EXTENSION MUST BE AT LEAST 2 CHARACTERS
rick@rick.c";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}