use strict;
my $str = '### SHOULD WORK
rick@rick.com
rick_1@rick.com
rick.a@rick.com
rick14@ric-k14.com
rick@rick.co.gov.uk
### SHOULD NOT WORK
# UNDERSCORE IS NOT FOLLOWED BY A LETTER OR NUMBER
rick_@rick.com
# DOT IS NOT FOLLOWED BY A LETTER OR NUMBER
rick.@rick.com
# NO SPACES ALLOWED
ri ck@rick.com
# UNDERSCORE NOT ALLOWED IN DOMAIN
rick@ri_ck.com
# EXTENSION MUST BE AT LEAST 2 CHARACTERS
rick@rick.c';
my $regex = qr~^(?:[A-Z\d]|[-_.](?=[A-Z\d]))+@[-A-Z\d.]+\.[A-Z]{2,}$~mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}