$re = '~^(?:[A-Z\d]|[-_.](?=[A-Z\d]))+@[-A-Z\d.]+\.[A-Z]{2,}$~mi';
$str = '### SHOULD WORK
rick@rick.com
rick_1@rick.com
rick.a@rick.com
rick14@ric-k14.com
rick@rick.co.gov.uk
### SHOULD NOT WORK
# UNDERSCORE IS NOT FOLLOWED BY A LETTER OR NUMBER
rick_@rick.com
# DOT IS NOT FOLLOWED BY A LETTER OR NUMBER
rick.@rick.com
# NO SPACES ALLOWED
ri ck@rick.com
# UNDERSCORE NOT ALLOWED IN DOMAIN
rick@ri_ck.com
# EXTENSION MUST BE AT LEAST 2 CHARACTERS
rick@rick.c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);