#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)commit:\s*(.*?)(?:\s*Commit\b|$)"
Local $sString = "commit: February 2021 Master DS Commit c285fcbf59b698ec5695d35989a420da7659" & @CRLF & _
"commit: March market Sales Volume PFJan2021" & @CRLF & _
"commit: August market Input PFJan2021" & @CRLF & _
"commit: February 2021 Master DS Commit c5695d359820da7659"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")