package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)commit:\s*(.*?)(?:\s*Commit\b|$)`)
var str = `commit: February 2021 Master DS Commit c285fcbf59b698ec5695d35989a420da7659
commit: March market Sales Volume PFJan2021
commit: August market Input PFJan2021
commit: February 2021 Master DS Commit c5695d359820da7659`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}