re = /commit:\s*(.*?)(?:\s*Commit\b|$)/m
str = 'commit: February 2021 Master DS Commit c285fcbf59b698ec5695d35989a420da7659
commit: March market Sales Volume PFJan2021
commit: August market Input PFJan2021
commit: February 2021 Master DS Commit c5695d359820da7659'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end