using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"server_info/([\.0-9]*):([0-9]*)";
string input = @"server_info/11.22.33.44:1234";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}