$re = '@server_info/([\.0-9]*):([0-9]*)@';
$str = 'server_info/11.22.33.44:1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);