package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`server_info/([\.0-9]*):([0-9]*)`)
var str = `server_info/11.22.33.44:1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}