package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d[\d,]*`)
var str = `1–16 of more than 8,000 results
1–1,1 of more, than 8,000 results 1,
,0123,123,123,654`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}