// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d[\d,]*").unwrap();
let string = "1–16 of more than 8,000 results
1–1,1 of more, than 8,000 results 1,
,0123,123,123,654";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}