re = /\d[\d,]*/m
str = '1–16 of more than 8,000 results
1–1,1 of more, than 8,000 results 1,
,0123,123,123,654'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end