#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ixu)# Definição de ordens" & @CRLF & _
"(?(DEFINE)(?P<unidades> um|dois|tr[eê]s|quatro|cinco|meia|se(?:is|te)|oito|nove ))" & @CRLF & _
"(?(DEFINE)(?P<dezenas_dez> d(?:ez(?:e(?:nove|sse(?:is|te))|oito)?|oze)|onze|treze|catorze|quinze ))" & @CRLF & _
"(?(DEFINE)(?P<dezenas_exceto_dez> vinte|trinta|(?:quar|cinqu|se(?:ss|t)|oit|nov)enta ))" & @CRLF & _
"(?(DEFINE)(?P<dezenas> (?P>dezenas_dez)|(?P>dezenas_exceto_dez) ))" & @CRLF & _
"(?(DEFINE)(?P<dezenas_ou_unidades> (?P>dezenas)|(?P>unidades) ))" & @CRLF & _
"(?(DEFINE)(?P<centenas> ce(?:m|ntos?)|(?:qu(?:atroc|inh)|(?:du|tre|se(?:is|te)|oito|nove)[cz])entos? ))" & @CRLF & _
"(?(DEFINE)(?P<mil> mil ))" & @CRLF & _
"(?(DEFINE)(?P<milhoes> (?:(?:[mb]|tr)i|qu(?:atri|inqua))lh(?:[aã]o|[oõ]es) ))" & @CRLF & _
"(?(DEFINE)(?P<s> [ ]+ ))" & @CRLF & _
"(?(DEFINE)(?P<e> e(?P>s) ))" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"#Regras" & @CRLF & _
"\b(?:" & @CRLF & _
"" & @CRLF & _
" #1. Entre dezenas>=20 e unidades" & @CRLF & _
" (?P>dezenas_exceto_dez)(?P>s)(?=(?P>unidades)\b)" & @CRLF & _
"|" & @CRLF & _
" #2. Entre centenas e dezenas ou unidades" & @CRLF & _
" (?P>centenas)(?P>s)(?=(?P>dezenas_ou_unidades)\b)" & @CRLF & _
"|" & @CRLF & _
" #3-4. Entre milhares..." & @CRLF & _
" (?P>mil)(?P>s)(?=" & @CRLF & _
" (?:" & @CRLF & _
" #3. ... e dezenas ou unidades" & @CRLF & _
" (?P>dezenas_ou_unidades)" & @CRLF & _
" |" & @CRLF & _
" #4. ... e centenas, somente se não houver dezenas ou unidades" & @CRLF & _
" (?P>centenas)(?!(?P>s)(?P>e)?(?P>dezenas_ou_unidades)\b)" & @CRLF & _
" )" & @CRLF & _
" \b" & @CRLF & _
" )" & @CRLF & _
"|" & @CRLF & _
" #5. Entre milhões e dezenas ou unidades (que não sejam unidades ou dezenas de milhões ou unidades ou dezenas de milhares)" & @CRLF & _
" (?P>milhoes)(?P>s)(?=" & @CRLF & _
" (?P>dezenas_ou_unidades)(?!(?P>s)(?P>e)?(?:(?P>unidades)(?P>s)(?P>e)?)?(?:(?P>milhoes)|(?P>mil))\b)\b" & @CRLF & _
" " & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
")" & @CRLF & _
"\b" & @CRLF & _
"" & @CRLF & _
"#Reset" & @CRLF & _
"\K"
Local $sString = "vinte cinco" & @CRLF & _
"vinte cinco mil" & @CRLF & _
"vinte cinco reais" & @CRLF & _
"vinte cinco reais e vinte cinco centavos" & @CRLF & _
"aaa bbb ccc" & @CRLF & _
"dois mil trezentos" & @CRLF & _
"dois mil trezentos quarenta cinco" & @CRLF & _
"dois milhões trinta um" & @CRLF & _
"dois milhões trinta um mil" & @CRLF & _
"dois milhões trinta mil" & @CRLF & _
"cento vinte três milhões quatrocentos cinquenta seis mil setecentos oitenta nove"
Local $sSubst = "e "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)