import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# Definição de ordens\n"
+ "(?(DEFINE)(?P<unidades> um|dois|tr[eê]s|quatro|cinco|meia|se(?:is|te)|oito|nove ))\n"
+ "(?(DEFINE)(?P<dezenas_dez> d(?:ez(?:e(?:nove|sse(?:is|te))|oito)?|oze)|onze|treze|catorze|quinze ))\n"
+ "(?(DEFINE)(?P<dezenas_exceto_dez> vinte|trinta|(?:quar|cinqu|se(?:ss|t)|oit|nov)enta ))\n"
+ "(?(DEFINE)(?P<dezenas> (?P>dezenas_dez)|(?P>dezenas_exceto_dez) ))\n"
+ "(?(DEFINE)(?P<dezenas_ou_unidades> (?P>dezenas)|(?P>unidades) ))\n"
+ "(?(DEFINE)(?P<centenas> ce(?:m|ntos?)|(?:qu(?:atroc|inh)|(?:du|tre|se(?:is|te)|oito|nove)[cz])entos? ))\n"
+ "(?(DEFINE)(?P<mil> mil ))\n"
+ "(?(DEFINE)(?P<milhoes> (?:(?:[mb]|tr)i|qu(?:atri|inqua))lh(?:[aã]o|[oõ]es) ))\n"
+ "(?(DEFINE)(?P<s> [ ]+ ))\n"
+ "(?(DEFINE)(?P<e> e(?P>s) ))\n\n\n"
+ "#Regras\n"
+ "\\b(?:\n\n"
+ " #1. Entre dezenas>=20 e unidades\n"
+ " (?P>dezenas_exceto_dez)(?P>s)(?=(?P>unidades)\\b)\n"
+ "|\n"
+ " #2. Entre centenas e dezenas ou unidades\n"
+ " (?P>centenas)(?P>s)(?=(?P>dezenas_ou_unidades)\\b)\n"
+ "|\n"
+ " #3-4. Entre milhares...\n"
+ " (?P>mil)(?P>s)(?=\n"
+ " (?:\n"
+ " #3. ... e dezenas ou unidades\n"
+ " (?P>dezenas_ou_unidades)\n"
+ " |\n"
+ " #4. ... e centenas, somente se não houver dezenas ou unidades\n"
+ " (?P>centenas)(?!(?P>s)(?P>e)?(?P>dezenas_ou_unidades)\\b)\n"
+ " )\n"
+ " \\b\n"
+ " )\n"
+ "|\n"
+ " #5. Entre milhões e dezenas ou unidades (que não sejam unidades ou dezenas de milhões ou unidades ou dezenas de milhares)\n"
+ " (?P>milhoes)(?P>s)(?=\n"
+ " (?P>dezenas_ou_unidades)(?!(?P>s)(?P>e)?(?:(?P>unidades)(?P>s)(?P>e)?)?(?:(?P>milhoes)|(?P>mil))\\b)\\b\n"
+ " \n"
+ " )\n\n"
+ ")\n"
+ "\\b\n\n"
+ "#Reset\n"
+ "\\K";
final String string = "vinte cinco\n"
+ "vinte cinco mil\n"
+ "vinte cinco reais\n"
+ "vinte cinco reais e vinte cinco centavos\n"
+ "aaa bbb ccc\n"
+ "dois mil trezentos\n"
+ "dois mil trezentos quarenta cinco\n"
+ "dois milhões trinta um\n"
+ "dois milhões trinta um mil\n"
+ "dois milhões trinta mil\n"
+ "cento vinte três milhões quatrocentos cinquenta seis mil setecentos oitenta nove";
final String subst = "e ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}