#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z]+(?:[^a-zA-Z]+[a-zA-Z]+){3}[^a-zA-Z]*$"
Local $sString = "blah blah blah blah blah." & @CRLF & _
"lkjhf lkjqsdf lkjhr ioqusr iortnb lkqjsdf mlkjj,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")