package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z]+(?:[^a-zA-Z]+[a-zA-Z]+){3}[^a-zA-Z]*$`)
var str = `blah blah blah blah blah.
lkjhf lkjqsdf lkjhr ioqusr iortnb lkqjsdf mlkjj,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}