const regex = new RegExp('\\bjava(?:\\.\\w+)+(*SKIP)(*FAIL)|(?<!/)\\b\\w+(?:\\.\\w+)+', 'gm')
const str = `test string (test.url.com) abcdef java.lang.Assertion uvwxyz www.google.com abcdef
another test string /abc/xyz/lib/def/GH.tr test 200.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}