re = /\bjava(?:\.\w+)+(*SKIP)(*FAIL)|(?<!\/)\b\w+(?:\.\w+)+/m
str = 'test string (test.url.com) abcdef java.lang.Assertion uvwxyz www.google.com abcdef
another test string /abc/xyz/lib/def/GH.tr test 200.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end