$re = '~\bjava(?:\.\w+)+(*SKIP)(*FAIL)|(?<!/)\b\w+(?:\.\w+)+~m';
$str = 'test string (test.url.com) abcdef java.lang.Assertion uvwxyz www.google.com abcdef
another test string /abc/xyz/lib/def/GH.tr test 200.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);