package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\|]+([a-z0-9A-Z]+)(?:[\(]?[,][\)]?)?[\|]?`)
var str = `|Func(param1, param2, param32, param54, param293, par13am, param)|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}