re = /[\|]+([a-z0-9A-Z]+)(?:[\(]?[,][\)]?)?[\|]?/
str = '|Func(param1, param2, param32, param54, param293, par13am, param)|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end