$re = '/[\|]+([a-z0-9A-Z]+)(?:[\(]?[,][\)]?)?[\|]?/';
$str = '|Func(param1, param2, param32, param54, param293, par13am, param)|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);