const regex = /((?![\s\-обед])[а-я]{2,3}|[а-я]{2,3}-[а-я]{2,3})[:\s]+([\d:\-]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?![\\s\\-обед])[а-я]{2,3}|[а-я]{2,3}-[а-я]{2,3})[:\\s]+([\\d:\\-]+)', 'gm')
const str = `пн: 10:00-19:00, обед: 14:00-15:00 вт: 10:00-19:00, обед: 14:00-15:00 ср: 10:00-19:00, обед: 14:00-15:00 чт: 10:00-19:00, обед: 14:00-15:00 пт: 10:00-19:00, обед: 14:00-15:00 сб: 10:00-14:00, обед: 14:00-15:00
пн-вск 20-22`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}