import Foundation
let pattern = #"((?![\s\-обед])[а-я]{2,3}|[а-я]{2,3}-[а-я]{2,3})[:\s]+([\d:\-]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
пн: 10:00-19:00, обед: 14:00-15:00 вт: 10:00-19:00, обед: 14:00-15:00 ср: 10:00-19:00, обед: 14:00-15:00 чт: 10:00-19:00, обед: 14:00-15:00 пт: 10:00-19:00, обед: 14:00-15:00 сб: 10:00-14:00, обед: 14:00-15:00
пн-вск 20-22
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)