re = /((?![\s\-обед])[а-я]{2,3}|[а-я]{2,3}-[а-я]{2,3})[:\s]+([\d:\-]+)/m
str = 'пн: 10:00-19:00, обед: 14:00-15:00 вт: 10:00-19:00, обед: 14:00-15:00 ср: 10:00-19:00, обед: 14:00-15:00 чт: 10:00-19:00, обед: 14:00-15:00 пт: 10:00-19:00, обед: 14:00-15:00 сб: 10:00-14:00, обед: 14:00-15:00
пн-вск 20-22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end