package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http(s)?:\/\/(.*?[^\/])*?\S+`)
var str = `Пока использую только функции разблокировки экрана, быстрого запуска приложений, частных записок, задач профиля и приложений, также будильник. http://site.ru/gertolgd
Работает хорошо при прикосновении определенной точкой кольца к задней стенке телефона. http://site.ru/geaafasf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}