$re = '/http(s)?:\/\/(.*?[^\/])*?\S+/m';
$str = 'Пока использую только функции разблокировки экрана, быстрого запуска приложений, частных записок, задач профиля и приложений, также будильник. http://site.ru/gertolgd
Работает хорошо при прикосновении определенной точкой кольца к задней стенке телефона. http://site.ru/geaafasf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);